MCP2 connection issue
Incident Report for NTT Ltd. Cloud
Resolved
Reported issue is now restored.
Posted May 27, 2018 - 06:04 UTC
Investigating
Due to a ongoing incident, users may experience issues connecting to Managed Hosting Servers.
Posted May 26, 2018 - 23:47 UTC
This incident affected: EU - United Kingdom (NTT Cloud EU8).